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LEGAL INFORMATION  
INFORMATION IN THIS DOCUMENT IS PROVIDED IN CONNECTION WITH INTEL® 

PRODUCTS. NO LICENSE, EXPRESS OR IMPLIED, BY ESTOPPEL OR OTHERWISE, TO 
ANY INTELLECTUAL PROPERTY RIGHTS IS GRANTED BY THIS DOCUMENT. EXCEPT AS 

PROVIDED IN INTEL'S TERMS AND CONDITIONS OF SALE FOR SUCH PRODUCTS, 
INTEL ASSUMES NO LIABILITY WHATSOEVER, AND INTEL DISCLAIMS ANY EXPRESS 

OR IMPLIED WARRANTY, RELATING TO SALE AND/OR USE OF INTEL PRODUCTS 
INCLUDING LIABILITY OR WARRANTIES RELATING TO FITNESS FOR A PARTICULAR 

PURPOSE, MERCHANTABILITY, OR INFRINGEMENT OF ANY PATENT, COPYRIGHT OR 
OTHER INTELLECTUAL PROPERTY RIGHT.  

UNLESS OTHERWISE AGREED IN WRITING BY INTEL, THE INTEL PRODUCTS ARE NOT 
DESIGNED NOR INTENDED FOR ANY APPLICATION IN WHICH THE FAILURE OF THE 

INTEL PRODUCT COULD CREATE A SITUATION WHERE PERSONAL INJURY OR DEATH 
MAY OCCUR.  

Intel may make changes to specifications and product descriptions at any time, 

without notice. Designers must not rely on the absence or characteristics of any 
features or instructions marked "reserved" or "undefined." Intel reserves these for 

future definition and shall have no responsibility whatsoever for conflicts or 
incompatibilities arising from future changes to them. The information here is subject 

to change without notice. Do not finalize a design with this information.  
The products described in this document may contain design defects or errors known 

as errata which may cause the product to deviate from published specifications. 
Current characterized errata are available on request.  

Contact your local Intel sales office or your distributor to obtain the latest 
specifications and before placing your product order.  

This document contains information on products in the design phase of development.  
All products, platforms, dates, and figures specified are preliminary based on current 

expectations, and are subject to change without notice. All dates specified are target 
dates, are provided for planning purposes only and are subject to change.  

This document contains information on products in the design phase of development. 

Do not finalize a design with this information. Revised information will be published 
when the product is available. Verify with your local sales office that you have the 

latest datasheet before finalizing a design.  
Code names featured are used internally within Intel to identify products that are in 

development and not yet publicly announced for release. Customers, licensees and 
other third parties are not authorized by Intel to use code names in advertising, 

promotion or marketing of any product or services and any such use of Intel's internal 
code names is at the sole risk of the user.  

Intel and the Intel logo are trademarks of Intel Corporation in the U.S. and other 
countries.  

*Other names and brands may be claimed as the property of others.  
Copyright © 2015-2022, Intel Corporation. All rights reserved.  
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1 Purpose of Intel® Processor Diagnostic Tool 

 

The purpose of the Intel® Processor Diagnostic Tool is to verify the functionality of an 
Intel® microprocessor. The diagnostic checks for brand identification, verifies the 

processor operating frequency, tests specific processor features and performs a stress 
test on the processor.  

 

The diagnostic can be configured to execute with various features enabled or disabled. 
For more details, see IPDT Features & Parameters 

 
 

2 IPDT Test System Requirements 

 

Multiprocessor Systems 
The Intel® Processor Diagnostic Tool is compatible with multiprocessor systems. 

Intel® Processor Diagnostic Tool supports parallel testing of multiple processors 

inserted into a multiprocessor system following all processor configuration rules for 
the platform. Please refer to your system manufacturer’s documentation for 

configuration requirements.   
However, in some specific cases it may be necessary that only one Intel® processor is 

tested at a time in a multi-socket system configuration. 
  

Motherboard & Processor 
It is essential that the motherboard you use to test your processor is fully compatible 

with your Intel® processor. Consult your motherboard manufacturer’s support to 
ensure the motherboard supports your processor.  If you are using an Intel® 

Motherboard please use this utility Intel® Processors and Boards Compatibility Tool 
 

Motherboard BIOS 
It is essential that the motherboards BIOS is at the minimum BIOS revision specified 

to support your Intel® processor. Consult your motherboard manufacturer’s support 

to ensure the BIOS revision is at the correct revision.  
 

Motherboard Architecture 
IPDT is only compatible with motherboards built using Intel® Architecture. 

 
Over-Clocking 

Over-Clocking should be disabled while running Intel® Processor Diagnostic Tool. 
  

https://compatibleproducts.intel.com/?Lang=en-US
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Power Management 
Some power management features (e.g. Intel SpeedStep® technology) throttle or 

reduce the operating frequency of components within the system. These types of 
power management features may result in very low tested frequency results. This 

does not mean that the processor is operating at degraded performance levels. It 
means that the enabled power management feature is optimizing the efficiency of the 

processor, either to save power or reduce heat within the system.  

We recommend you disable any power management features such as Intel 
SpeedStep® technology and configure your system to its optimal power management 

settings, when running Intel® Processor Diagnostic Tool. For instructions on how to 

disable these power management features, please contact your system manufacturer. 

 

 
Operating Systems 

The Windows® version of the Intel® Processor Diagnostic Tool is compatible with the 

following operating systems (Please download and install the relevant IPDT installer 
for your Operating System – 32Bit or 64Bit): 

 
• Windows 11® 64 Bit (all versions) 

• Windows 10® 32 & 64 Bit (all versions) – except Windows® RT 
• Windows Server 2022® Standard/Datacenter 

• Windows Server 2019® Standard/Datacenter 
• Windows Server 2016® Standard/Datacenter 

• Windows Server 2012® R2 Standard/Enterprise 
 

 

3 Acronyms 

 

Acronym Definition 

CPU Central Processing Unit 

GUI Graphical User Interface 

QPI QuickPath Interconnect 

IMC Integrated Memory Controller 

IPDT Intel® Processor Diagnostic Tool 

MSR Model Specific Register 

AVX Advanced Vector Extensions 

OS Operating System 

 

http://www.intel.com/support/processors/sb/cs-028855.htm
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4 Software Required 

 

The following software is required to run either IPDT or IPDT64 in the Windows® 
environment and must be installed prior to installation of IPDT or IPDT64. 

 

Software Requirements (32 Bit or 64 Bit) 

 

• Microsoft® .NET Framework Version 4.8 Redistributable Package (x86_x64).  
Click here to download or copy the following URL into the browser 

https://dotnet.microsoft.com/en-us/download/dotnet-framework/net48.   
 

Additional support information about the .NET 4.8 Runtime is available here from 
Microsoft®. The IPDT Installer program will check for the presence of this minimum 

prerequisite on your system and provide the following prompt if it is necessary to 
update this software.  

 

 

 
 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

 
 

https://dotnet.microsoft.com/en-us/download/dotnet-framework/net48
https://dotnet.microsoft.com/en-us/download/dotnet-framework/net48
https://support.microsoft.com/en-us/topic/microsoft-net-framework-4-8-offline-installer-for-windows-9d23f658-3b97-68ab-d013-aa3c3e7495e0
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5 Installing IPDT in the Windows Environment 

 

Installation Process 
Copy the IPDT Installer program (either 32 bit or 64 bit depending on your OS 

version) to the desktop or other preferred location. Double-click on it and the dialog 
box below will be shown. 

 

Click Next button to continue to the IPDT prerequisite check. 
 

 
 

If you require .NET 4.8 prerequisite, and with active internet connection provided, the 
Setup program will download the .NET web installation package from Microsoft® site 

by selecting Yes.  

 

 
 
If no internet connection is available, the No button can be selected to terminate 

Setup. An alternate offline installation .NET redistributable package can be provided 
as indicated in Section 4 of this document. Then you may proceed with IPDT Setup 

installation again. 
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After prerequisite check is successful the following Confirmation message will be 

displayed. Select Next button to continue installation. 
 

 
 
 

Read complete License Agreement and follow instructions as indicated in message box 
below. You must accept the terms of this license agreement in order to continue with 

the installation.   
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The following User Account Control message will allow IPDT Setup to continue by 

selecting Yes button. 
 

 
 

Setup will indicate completion of installation as illustrated below, and an application 

shortcut will be added to the desktop.    
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6 Running IPDT from GUI 

 

IPDT can be launched by either using the desktop shortcut or selecting “Intel 
Processor Diagnostic Tool 64bit” from the Apps Menu. 

 

 
  

When launched IPDT will display the message below momentarily as it detects system 
configuration.  

 

 
 

IPDT will then begin execution of the diagnostic using the default configuration based 
on the CPU model. 
 

 
 

System information is shown in the top left window.  
Test Summary window with progress bar is shown in the bottom left window.  

Test Results and configuration settings are shown in the top right window. 
Detailed test output is shown in the bottom right window. 
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When IPDT completes, the Testing Status will display either a PASS or FAIL.  
 

 
 
The FAIL screen is shown below. 
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At the top of the IPDT GUI Window is a Menu Bar. The “File” Menu allows you to open 
the TestResults.txt file using Notepad, and allows you to exit IPDT.  

You may also view the full historical test results file to show all IPDT test results from 
each subsequent test run. See below: 

 

 
 

The “Tools” menu will allow you to open Config menu, turn off/on Looping, Check for 

Update, Launch Task Manager and Shutdown System. See below: 
 

 
  
Tools → Config menu is only available when IPDT is not executing tests. 

Tools → Config → Reset to Defaults. This will reset your Features & Parameters to 

default values. 
Tools → Config → Edit. This will allow you to edit and Enable/Disable test modules.  

Tools → Config → Presets allows you to set IPDT to 3 preset settings of operation 
Presets → Quick Test sets all IPDT features to disabled. Run Genuine Intel, 

Brand String and Frequency Test only. 

Presets → Full Functional Test enables all IPDT features and runs IPDT stress 
tests for total time of approximately 4 minutes. This is the default IPDT setting. 

Presets → Burn-In Test enables all IPDT features and runs IPDT stress tests for 
approximately 3 hours. You may also turn on looping with this Burn-In setting. 
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Tools → Looping → On or Off. Set to ON, this will loop/test IPDT continuously until you 
turn Looping to OFF. “Stop Testing on Fail” will halt on a failure by default. See below. 

 

 
 
Tools → “Stop Testing On Fail” will allow you to set IPDT to stop when a failure is 

detected (default) or continue test loop after a failure if set to “Off”. 
 

 
 

Tools → “Launch Task Manager” will launch your systems Task Manager, where you 
can view the systems performance while IPDT is running. 
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Tools → Check for Update → “Check for Update Now” will check your version of IPDT 
against the latest IPDT version online and display a message if your version of IPDT is 

lower. 
Tools → Check for Update → “Auto Update Check On” will enable IPDT to check its 

version online every time IPDT is launched. “Auto Update Check Off” will turn off IPDT 
checking online when IPDT launches. 

 

 
 

Tools → “Online Warranty Check” will bring you directly to Intel’s online warranty 
support page where you can check Intel Processor warranty information. 

 

 
 

Tools → “Shutdown System” will shut down your system. A warning message is 
displayed to confirm that you really want to power off your system. 
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View → “Full”. This will display the full IPDT view which is the default. 
 

 
 

 

View → “Compact”. Will display a compact view of IPDT. Useful when running IPDT 

while viewing Task Manager. See below for compact IPDT view. 
 

 
 
 

About → “Help” Menu opens this IPDT Help document. See below. 
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The CPU Features tab will display all the features supported by your processor. 
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When IPDT is launched it will automatically check if an updated version of IPDT exists 
at downloadcenter.intel.com 

 
 

 
 

If you would like to update your version of IPDT simply click on the option “Go to IPDT 

Download location”. This will take you to the download location of the latest version of 
IPDT on downloadcenter.intel.com website. 

If you do not wish to download the latest version of IPDT at this time, simply select 
the option “Close this message Run IPDT”. IPDT will check for the latest version on 

subsequent launches of IPDT. 
If you would like to turn off the automatic checking for updated versions of IPDT on 

future launches, simply tick the box “Do not check for IPDT updates in future”. 
 

 
 

 
 

 
 

 

 
 

 
 

 

https://downloadcenter.intel.com/download/19792
https://downloadcenter.intel.com/download/19792
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7 Running IPDT in a Multi-Processor System 

The 64bit version of IPDT can test multiple Intel Processors installed in a multi-

Processor capable system. IPDT will automatically detect if you have multiple Intel 
Processors installed and run the IPDT test modules on each processor. 
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8 Running IPDT Test Modules from command line 

 

Individual IPDT Test Modules may be launched directly using the standalone IPDT Test 
Modules .exe executables located in the C:\Programs Files\Intel Corporation\Intel 

Processor Diagnostic Tool (64bit)\ folder. 
 

This allows for IPDT Test Modules to be easily integrated into a 3rd party diagnostic or 

to be run manually from a command window. 
 

To run IPDT Test Modules from a command window: 
Open a Command Prompt Window, right click and select “Run as administrator” as 

indicated below. 
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The following IPDT Test Modules may be run in command line: 

Run <ModuleName.exe> -h to view the specific command line options for each IPDT 
Test Module, example: Genintel.exe –h 

 
IPDT Test Module Description Command line switches 

Genintel.exe Checks if Processor is a Genuine Intel 

Processor 

-h -c 

Brandstring.exe Checks the brand string of the 

processor 

-h -c 

Math_FP.exe Floating Point Test -h -nc –s –errstop -c 

Math_PrimeNum.exe Prime Number Test -h -nc –s –errstop -c 

Cache.exe Processor Cache Test -h –pa -c 

MMXSSE.exe MMX and SSE Test -h –pa -c 

AVX.exe AVX Test -h –pa -s -c 

FMA3.exe FMA Test -h -pa -s -c 

IMC.exe Integrated Memory Test -h –nc –skipsize  

–skipstress –c –expsize 

-sizetol 

GraphicsW.exe Visual Graphics GPU Test -h -hrs –m –s –c 

GPUStressW.exe GPU Stress Test for 64bit OS only -h -hrs –m –s –c  

dgemm.exe CPU Load Test -h -hrs –m –s –c  

FrequencyCheck.exe CPU Frequency Test -h –c -nc 

 
-h = help -skipsize = Skip IMC Size Test 

-nc = No Compare. Skip comparison test. -expsize = Set IMC Expected Memory Size 

-hrs = Hours –m= Minutes –s = Seconds -skipstress = Skip IMC Memory Stress 

-pa = Pause app on completion. -sizetol = IMC Memory Size tolerance % 

-c = Use color display. Red for Fail. Green for 

Pass. Yellow for indeterminate. 

-errstop = toggles Stop-on-Error option  
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9 IPDT Configuration   
 

You can configure IPDT from the Tools → Config → Edit menu. 

IPDT may only be configured after IPDT testing has been stopped or has completed 
testing. 

Test Modules can be enabled or disabled. Parameters can be changed in value. 

See here for more description on each IPDT feature and parameter. 
Click on each Test Module to get an output of the -h (help) for that module. 

 
Please note: Running IPDT with settings other than the default settings could possibly 

give a result that may not indicate a genuine fault with your Intel Processor. 
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10 IPDT Features & Parameters  
 

 

Test Module Genuine Intel Test 

Description and 

Options 

 

Module Executable = GenIntel.exe 

GenIntel.exe reads the General Specific Register and compares it to 

"GeniuneIntel". If the read value matches the expected value, the test will pass. 

 

Possible options are as follows: 

 

 -h          = Help or Usage (this message) 

               Example: 

               GenIntel.exe -h 

 

 -info       = Information switch publishes parallel information 

               using the following scheme: 

               "parallel:yes|socket:yes|core:yes" 

               Example: 

               GenIntel.exe -info 

 

 -resultName = The resultName switch provides a way to name  

               the results file as desired. 

               This is for the convenience of the control program.  

               Example: 

               GenIntel.exe -resultName GenIntel_results_01.txt  

 

 -c          = If present, this option will display text in various colors 

               Example: 

               GenIntel.exe –c 
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Test Module Brand String Test 

Description and 

Options 

 

Module Executable = BrandString.exe 

BrandString.exe reads the brand string parts from the CPU and compares them 

 against parts from a configuration file.  If all expected parts from the  

 configuration file are found in the parts from the CPU, the test will pass. 

 

Possible options are as follows: 

 

 -h          = Help or Usage (this message) 

               Example: 

               BrandString.exe -h 

 

 -info       = Information switch publishes parallel information 

               using the following scheme: 

               "parallel:yes|socket:yes|core:yes" 

               Example: 

               BrandString.exe -info 

 

 -resultName = The resultName switch provides a way to name  

               the results file as desired. 

               This is for the convenience of the control program.  

               Example: 

               BrandString.exe -resultName BrandString_results_01.txt  

 

 -c          = If present, this option will display text in various colors 

               Example: 

               BrandString.exe -c 
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Test Module Floating Point Test 

Description and 

Options 

 

Math_FP.exe performs floating point mathematic operation. 

 

Possible options are as follows: 

 

 -h           = Help or Usage (this message) 

                Example: 

                Math_FP.exe -h 

 

 -info        = Information switch publishes parallel information 

                using the following scheme: 

                "parallel:yes|socket:yes|core:yes" 

                Example: 

                Math_FP.exe -info 

 

 -resultName = The resultName switch provides a way to name  

                the results file as desired. 

                This is for the convenience of the control program.  

                Example: 

                Math_FP.exe -resultName Math_FP_results_01.txt  

 

 -c           = If present, this option will display text in various colors 

                Example: 

                Math_FP..exe -c 

 

 -nc          = Skip the result, will display only. 

                Example: 

                Math_FP.exe -nc  

 

 -errstop     = Stop on error, default is continue on error. 

                Example: 

                Math_FP.exe -errstop  

 

 -s [d]       = Time in seconds to perform the test 

                default is 2 seconds. 

                Example: 

                Math_FP.exe -s 5 

 

Dependencies: 

 

          DetectUtils64.dll or DetectUtils.dll 

          libiomp5md.dll 
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Test Module Prime Number Generation Test 

Description and 

Options 

 

Module Executable = Math_PrimeNum.exe  

Math_PrimeNum.exe checks how fast the CPU can search for prime number. 

 

Possible options are as follows: 

 

 -h           = Help or Usage (this message) 

                Example: 

                Math_PrimeNum.exe -h 

 

 -info        = Information switch publishes parallel information 

                using the following scheme: 

                "parallel:yes|socket:yes|core:yes" 

                Example: 

                Math_PrimeNum.exe -info 

 

 -resultName  = The resultName switch provides a way to name  

                the results file as desired. 

                This is for the convenience of the control program.  

                Example: 

                Math_PrimeNum.exe -resultName Math_PrimeNum_results_01.txt  

 

 -avx        = The AVX switch allows for selection of AVX instruction set  

                to use for test execution up to Max AVX supported by CPU:  

                0 = No AVX, 1 = AVX, 2 = AVX2, 3 = AVX512.  

                Example: 

                Math_PrimeNum.exe -avx 0 

 

 -c           = If present, this option will display text in various colors 

                Example: 

                Math_PrimeNum.exe -c 

 

 -nc          = Skip the result, will display only. 

                Example: 

                Math_PrimeNum.exe -nc  

 

 -errstop     = Stop on error, default is continue on error. 

                Example: 

                Math_PrimeNum.exe -errstop  

 

 -s [d]       = Time in seconds to perform the test 

                default is 2 seconds. 

                Example: 

                Math_PrimeNum.exe -s 5 

 

Dependencies: 

 

          DetectUtils64.dll or DetectUtils.dll 

          libiomp5md.dll 
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Test Module Cache Test 

Description and 

Options 

 

Module Executable = Cache.exe  

The purpose of CPU Cache test is to display the size of the 

 L1, L2, and L3 Cache, whichever is present. 

 The CPUID instruction is used to read the general purpose  

 EAX, EBX, ECX, and EDX registers. 

 The test retrieves the L1, L2, and L3 Cache size information 

  

Possible options are as follows: 

 

-h           = Help or Usage (this message) 

              Example: cache.exe -h 

 

-info        = Information switch that publishes parallel information 

              using the following scheme: parallel:yes|socket:yes|core:yes  

              Example: cache.exe -info 

 

-resultName = The resultName switch provides a way to name  

              the results file as desired. 

              Example: cache.exe -resultName cache_results_0001.txt  

 

-pa         = pause app option 

              Example: cache.exe -pa 

 

-c           = This option will display text in various colors 

              Example: cache.exe –c 
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Test Module MMX/SSE Test 

Description and 

Options 

 

Module Executable = MMXSSE.exe  

This test detects which MMX & SSE, SSE2, SSE3, SSSE3, SSE4 instruction sets 

 are supported on the processor being tested. 

 If the instruction set is supported then the test will execute all 

 MMX & SSE instructions for the supported instruction sets. 

 The test will display which features were detected and what was tested. 

  

Possible options are as follows: 

 

 -h           = Help or Usage (this message) 

                Example: 

                MMXSSE.exe -h 

 

 -info        = Information switch that publishes parallel information 

                using the following scheme: 

               "parallel:yes|socket:yes|core:yes"  

                Example: 

                MMXSSE.exe -info 

 

 -resultName  = The resultName switch provides a way to name  

                the results file as desired. 

                Example : 

                MMXSSE.exe -resultName MMXSSE_results_0001.txt  

 

 -pa          = pause app option 

                Example: 

                MMXSSE.exe -pa 

 

 -c           = This option will display text in various colors 

                Example: 

                MMXSSE.exe -c 
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Test Module AVX Test 

Description and 

Options 

 

Module Executable = AVX.exe  

Advanced Vector Extensions (AVX) is a 256 bit instruction set extension 

 to SSE and is designed for applications that are Floating Point intensive.  

 The purpose of the AVX test is to detect and test the presence of the 

 following AVX features on your Intel processor: 

        AVX (Advanced Vector Extensions) 

        AES (Advanced Encryption Standard) 

        PCLMULQDQ (Carry-Less Multiplication of two 64 bit operands) 

 Note: AVX capability is first detected on your Intel Processor and then it is 

 detected, to check if your operating system supports AVX. 

 Operating Systems that support AVX: 

 Windows 10, Windows8, Windows 7 SP1, Windows Server 2008 R2 SP1, 

  AVX Test Description: 

 Execute a FIR (Finite Impulse Response) filter using conventional code 

 instructions and then execute using AVX instructions. 

 Compare the results of both methods of calculation end expect the same 

 results. Also compare code execution times, expecting AVX optimized 

 code to execute faster than conventional non AVX-optimized code. 

  AES Test Description: 

 Decrypt & Encrypt data using aesdec, aesdeclast, aesenc and aesenclast 

 instructions. Also perform the InverseMixColumn aesimc and generate 

 round key for AES encryption using aeskeygenassist instruction. 

  PCLMULQDQ Test Description: 

 Perform a Carry-less multiplication of one quadword of xmm2 by one quadword 

 of xmm3/m128, returning a double quadword in register xmm1. 

  

Possible options are as follows: 

 -h           = Help or Usage (this message) 

                Example: AVX.exe -h 

 

 -info        = Information switch that publishes parallel information 

                using the following scheme: 

               "parallel:yes|socket:yes|core:yes"  

                Example: AVX.exe -info 

 

 -resultName  = The resultName switch provides a way to name  

                        the results file as desired. 

                Example: AVX.exe -resultName AVX_results_0001.txt  

 

 -pa          = pause app option 

                Example: AVX.exe -pa 

 

 -c            = This option will display text in various colors 

                Example:  AVX.exe –c 

 

Dependencies: 

 

                DetectUtils64.dll or DetectUtils.dll 

                libiomp5md.dll 
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Test Module FMA Test 

Description and 

Options 

Module Executable = FMA3.exe  

FMA3 Test Module detects and tests the following Intel Processor Features 

  

FMA3 - Fused Multiply Add Instruction 

  

Some features may be dependent on your Operating System 

Operating Systems that support FMA3: 

Windows 10, 8, 7 SP1, Windows Server 2008 R2 SP1, 

  

Possible options are as follows: 

-h           = Help or Usage (this message) 

                Example: 

                fma3.exe -h 

 

-s           = Time in seconds to perform the test 

                default is 5 seconds. 

                Example: 

                fma3.exe -s 10 

 

 -m           = Time in minutes to perform the test 

                default is 5 seconds. 

                Example: 

                fma3.exe -m 5 

 

 -hrs          = Time in hours to perform the test 

                default is 5 seconds. 

                Example: 

                fma3.exe -hrs 1 

 

 -resultName = The resultName switch provides a way to name  

                the results file as desired. 

                Example: 

                fma3.exe -resultName fma3_results_0001.txt  

 

 -c           = This option will display text in various colors 

                Example: 

                fma3.exe -c 

 

 -info        = Information switch that publishes parallel information 

                using the following scheme: 

               "parallel:yes|socket:yes|core:yes"  

                Example: 

                fma3.exe -info 

 

 -pa          = pause app option 

                Example: 

                fma3.exe -pa 

 

Dependencies: 

          DetectUtils64.dll or DetectUtils.dll 

          libiomp5md.dll 
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Test Module Integrated Memory Controller Test   

Description and 

Options 

 

Module Executable = IMC.exe  

IMC.exe displays or compares the value between expected and detected 

memory, performs simple memory patterns test. 

IMC.exe has memory size subtest and memory stress subtest. 

 

Possible options are as follows: 

-h           = Help or Usage (this message). 

              Example: IMC.exe -h 

 

-info       = Information switch publishes parallel information 

              using the following scheme: parallel:yes|socket:yes|core:yes 

              Example: IMC.exe -info 

 

-resultName = The resultName switch provides a way to name  

              the results file as desired. 

              Example: IMC.exe -resultName IMC_results_01.txt  

 

-c           = If present, this option will display result text in various colors. 

              Example: IMC.exe -c 

 

-nc         = No compare option, will display result only. 

              Example: IMC.exe -nc  

 

-skipsize = Skip memory size test. 

              Example: IMC.exe -skipsize  

 

-skipstress = Skip memory stress test. 

              Example: IMC.exe -skipstress  

 

-expsize [d.d] [KB|MB|GB] = Define expected memory size available. 

              As default, detected memory size available is displayed only. 

              If this option is defined, test will compare the expected and 

              detected memory size with default tolerance of 10%. 

              Example: IMC.exe -expsize 3.5GB  

 

-sizetol [d.d] = Define memory size tolerance accepted if -expsize is defined. 

              Default memory size tolerance is 0.1 (10%). 

              Example: IMC.exe -expsize 4.0gb -sizetol 0.01   
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Test Module Visual Graphics Test – GraphicsW 

Description and 

Options 

 

Module Executable = GraphicsW.exe 

The purpose of GraphicsW.exe is to exercise the GPU device on the Intel 

processor. It is developed to run on Intel core processors supporting OpenGL 

version 2.1 and higher. 

  

Possible options are as follows: 

 -h          = Help or Usage (this message) 

               Example: 

               GraphicsW.exe -h 

 

 -info       = Information switch publishes parallel information 

               using the following scheme: 

               "parallel:yes|socket:yes|core:yes" 

               Example: 

               GraphicsW.exe -info 

 

 -resultName = The resultName switch provides a way to name  

               the results file as desired. 

               This is for the convenience of the control program.  

               Example: 

               GraphicsW.exe -resultName GraphicsW_results_01.txt  

 

 -s          = Run GraphicsW for x number of seconds. 

               Example: 

               GraphicsW.exe -s 15 

 

-m          = Run GraphicsW for x number of minutes. 

               Example: 

               GraphicsW.exe -m 10 

 

<Esc>     = Escape key will terminate execution of GraphicsW.exe. 

 

Dependencies: 

 

               IMG768.bmp 

               Intel Graphics Driver 
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Test Module GPU Stress Test 

Description and 

Options 

 

Module Executable = GPUStressW.exe  

The purpose of GPU Stress is to add a mathematical load to the GPU device on 

the Intel processor.  GPUStressW is developed to run on Intel 6th generation 

core processors and newer. Note: this module is only supported on 64bit OS. 

 

Possible options are as follows: 

 -h = Help or Usage (this message) 

 

 -info = Information switch publishes parallel information for 

            the control program. 

            Format:  

            "parallel:(yes or no) |socket:(yes or no) |core:(yes or no)" 

            Example: 

            GPUStressW.exe -info "parallel:yes|socket:yes|core:yes"  

 

 -resultName = The resultName switch provides a way to name  

            the results file as desired. 

            This is for the convenience of the control program.  

            Example: 

            GPUStressW.exe -resultName GPUStressW_results_0001.txt  

 

 -c = If present, this option will display text in various colors 

 

 -hrs = hours option ...  

           Use: GPUStressW.exe -hrs <integer value>  

           Indicating the number of hours GPUStressW should run 

 

 -m = minutes option ...  

           Use: GPUStressW.exe -m <integer value>  

           Indicating the number of minutes GPUStressW should run 

 

 -s = seconds option ...  

           Use: GPUStressW.exe -s <integer value>  

           Indicating the number of seconds GPUStressW should run 

 

Example: GPUStressW.exe -s 45 

          In this example, GPUStressW will run for 45 seconds. 

 

Dependencies: 

           

Intel 6th Generation Core Processor or Newer with Integrated Graphics 

        Windows DCH Drivers for Intel Graphics 

        NBODY.exe 

        libmmd.dll 

        svml_dispmd.dll 

        pi_level_zero.dll 

        sycl6.dll 
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Test Module CPU Load Test 

Description and 

Options 

 

Module Executable = dgemm.exe  

CPU Load test stresses the processor using Intel® Math Kernel Library (MKL)  

 For Matrix Multiply algorithm to load all processor cores in parallel. The test will 

detect the presence and utilize the highest level of the following features on your 

Intel processor: 

         AVX512 (Advanced Vector Extensions 512), 

         AVX2 (Advanced Vector Extensions 2), 

         AVX (Advanced Vector Extensions), or 

         SSE4.2 (Streaming SIMD Extensions 4.2). 

     Note: AVX capability is first detected on your Intel Processor and then your      

     Operating System is checked to see if it supports running AVX. 

         Minimum Operating System versions that support AVX:  

              Windows 7 SP1, Windows Server 2008 R2 SP1  

 

Possible options are as follows: 

 

 -h = Help or Usage (this message) 

 

 -info = Information switch publishes parallel information for 

            the control program. 

            Format: "parallel:(yes or no) |socket:(yes or no) |core:(yes or no)" 

            Example: dgemm.exe -info "parallel:yes|socket:yes|core:yes"  

  

-resultName = The resultName switch provides a way to name  

             the results file as desired. 

             This is for the convenience of the control program.  

             Example: dgemm.exe -resultName CPULoad_results_0001.txt  

 

 -c = If present, this option will display text in various colors 

 

 -hrs = hours option ...  

        Use: dgemm.exe -hrs <integer value>  

        Indicating the number of hours CPU Load should run 

  

-m = minutes option ...  

        Use: dgemm.exe -m <integer value>  

        Indicating the number of minutes CPU Load should run 

 

 -s = seconds option ...  

        Use: dgemm.exe -s <integer value>  

        Indicating the number of seconds CPU Load should run 

        Example: dgemm.exe -s 45 

        In this example, CPU Load will run for 45 seconds. 

 

 

Dependencies: 

           

          DetectUtils64.dll or DetectUtils.dll 

          libiomp5md.dll 
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Test Module CPU Frequency Test 

Description and 

Options 

 

Module Executable = FrequencyCheck.exe  

FrequencyCheck.exe compares the value between measured CPU frequency and 

expected CPU frequency as stamped in the product Brand String.  

 

Options are as follows: 

 -h           = Help or Usage (this message) 

                Example: 

                FrequencyCheck.exe -h 

  

 -info        = Information switch publishes parallel information 

                using the following scheme: 

                "parallel:yes|socket:yes|core:yes" 

                Example: 

                FrequencyCheck.exe -info 

  

 -resultName = The resultName switch provides a way to name  

                the results file as desired. 

                This is for the convenience of the control program.  

                Example: 

                FrequencyCheck.exe -resultName FrequencyLog_01.txt  

 

 -c           = If present, this option will display text in various colors 

                Example: 

                FrequencyCheck.exe -c 

  

 -nc          = Skip the comparison test between expected and 

                measured CPU frequency 

                Example: 

                FrequencyCheck.exe -nc   
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Test Results File Name  

Description 

 

The output Test Results file is called TestResults.txt. 

A full listing of all subsequent test results is stored in TestResults_Full.txt   
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